sunxi-tools-1.2.ebuild 621 B

12345678910111213141516171819202122232425262728
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit eutils toolchain-funcs
  5. MY_PV="v${PV}"
  6. SRC_URI="https://github.com/linux-sunxi/sunxi-tools/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
  7. DESCRIPTION="Tools for Allwinner A10 devices."
  8. HOMEPAGE="http://linux-sunxi.org/"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. IUSE=""
  12. KEYWORDS="~amd64"
  13. DEPEND="virtual/libusb"
  14. src_compile() {
  15. emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} -std=c99 -D_POSIX_C_SOURCE=200112L -Iinclude/" all misc
  16. }
  17. src_install() {
  18. dobin bin2fex bootinfo fel fex2bin fexc nand-part phoenix_info pio
  19. }