u-boot-tools-2016.11.ebuild 977 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit toolchain-funcs
  5. MY_P="u-boot-${PV/_/-}"
  6. DESCRIPTION="utilities for working with Das U-Boot"
  7. HOMEPAGE="http://www.denx.de/wiki/U-Boot/WebHome"
  8. SRC_URI="ftp://ftp.denx.de/pub/u-boot/${MY_P}.tar.bz2"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~arm ~arm64 ~x86"
  12. IUSE=""
  13. S=${WORKDIR}/${MY_P}
  14. src_compile() {
  15. # Unset a few KBUILD variables. Bug #540476
  16. unset KBUILD_OUTPUT KBUILD_SRC
  17. emake defconfig
  18. emake \
  19. HOSTSTRIP=: \
  20. STRIP=: \
  21. HOSTCC="$(tc-getCC)" \
  22. HOSTCFLAGS="${CFLAGS} ${CPPFLAGS}"' $(HOSTCPPFLAGS)' \
  23. HOSTLDFLAGS="${LDFLAGS}" \
  24. CONFIG_ENV_OVERWRITE=y \
  25. tools-all
  26. }
  27. src_install() {
  28. cd tools || die
  29. dobin bmp_logo dumpimage fdtgrep gen_eth_addr img2srec mkenvimage mkimage
  30. dobin easylogo/easylogo
  31. dobin env/fw_printenv
  32. dosym fw_printenv /usr/bin/fw_setenv
  33. insinto /etc
  34. doins env/fw_env.config
  35. doman "${S}"/doc/mkimage.1
  36. }