fsharp-4.0.1.20.ebuild 539 B

12345678910111213141516171819202122232425262728
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. AUTOTOOLS_AUTORECONF=1
  5. inherit autotools-utils mono-env
  6. DESCRIPTION="The F# Compiler"
  7. HOMEPAGE="https://github.com/fsharp/fsharp"
  8. SRC_URI="https://github.com/fsharp/fsharp/archive/${PV}.tar.gz -> ${P}.tar.gz"
  9. LICENSE="Apache-2.0"
  10. SLOT="0"
  11. KEYWORDS="~x86 ~amd64"
  12. IUSE=""
  13. MAKEOPTS+=" -j1" #nowarn
  14. DEPEND=">=dev-lang/mono-3"
  15. RDEPEND="${DEPEND}"
  16. AUTOTOOLS_IN_SOURCE_BUILD=1
  17. src_install() {
  18. autotools-utils_src_install
  19. }