jwasm-2.10-r1.ebuild 886 B

123456789101112131415161718192021222324252627282930313233343536373839404142
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils toolchain-funcs versionator
  5. # 2.10 -> 210s
  6. MY_PN=JWasm
  7. MY_PV="$(delete_version_separator 1)s"
  8. MY_P="${MY_PN}${MY_PV}"
  9. DESCRIPTION="MASM-compatible TASM-similar assembler (fork of Wasm)"
  10. HOMEPAGE="http://www.japheth.de/JWasm.html"
  11. SRC_URI="http://www.japheth.de/Download/${MY_PN}/${MY_P}.zip"
  12. LICENSE="Watcom-1.0"
  13. SLOT="0"
  14. KEYWORDS="~amd64 ~x86"
  15. RDEPEND=""
  16. DEPEND=""
  17. S="${WORKDIR}"
  18. src_prepare() {
  19. epatch "${FILESDIR}"/${P}-gcc-4.8-fwdecl.patch
  20. epatch "${FILESDIR}"/${P}-types-test.patch
  21. epatch "${FILESDIR}"/${P}-uint_32-on-amd64.patch
  22. # don't strip binary
  23. sed -i GccUnix.mak -e 's/ -s / /g' || die
  24. }
  25. src_compile() {
  26. emake -f GccUnix.mak CC="$(tc-getCC) ${CFLAGS} ${LDFLAGS}"
  27. }
  28. src_install() {
  29. dobin GccUnixR/jwasm
  30. dodoc *.txt Doc/*.txt
  31. }