jwasm-2.11a.ebuild 810 B

12345678910111213141516171819202122232425262728293031323334353637383940
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils toolchain-funcs versionator
  5. # 2.10 -> 210s
  6. MY_PN=JWasm
  7. MY_PV="$(delete_version_separator 1)s"
  8. MY_P="${MY_PN}${MY_PV}"
  9. DESCRIPTION="MASM-compatible TASM-similar assembler (fork of Wasm)"
  10. HOMEPAGE="https://sourceforge.net/projects/jwasm/"
  11. SRC_URI="mirror://sourceforge/${PN}/JWasm%20Source%20Code/${MY_P}.zip"
  12. LICENSE="Watcom-1.0"
  13. SLOT="0"
  14. KEYWORDS="~amd64 ~x86"
  15. RDEPEND=""
  16. DEPEND=""
  17. S="${WORKDIR}"
  18. src_prepare() {
  19. epatch "${FILESDIR}"/${PN}-2.11-types-test.patch
  20. # don't strip binary
  21. sed -i GccUnix.mak -e 's/ -s / /g' || die
  22. }
  23. src_compile() {
  24. emake -f GccUnix.mak CC="$(tc-getCC) ${CFLAGS} ${LDFLAGS}"
  25. }
  26. src_install() {
  27. dobin GccUnixR/jwasm
  28. dodoc *.txt Doc/*.txt
  29. }