pasm-1.7.ebuild 654 B

1234567891011121314151617181920212223242526272829
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit eutils
  4. DESCRIPTION="A portable assembler for processors of the PowerPC family"
  5. SRC_URI="http://devnull.owl.de/~frank/${PN}.tar.gz"
  6. HOMEPAGE="http://sun.hasenbraten.de/~frank/projects/"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. IUSE=""
  10. KEYWORDS="~ppc ~ppc-macos"
  11. src_unpack() {
  12. mkdir -p "${S}"/LinuxPPC
  13. cd "${S}"
  14. unpack ${A}
  15. epatch "${FILESDIR}/${P}-ppc.patch"
  16. }
  17. src_compile() {
  18. emake || die "Compilation failed"
  19. }
  20. src_install () {
  21. dobin pasm || die "Failed to install pasm binary"
  22. dodoc pasm.doc || die "Failed to install pasm documentation"
  23. }