python-exec-2.0.2.ebuild 1007 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. # Kids, don't do this at home!
  5. inherit python-utils-r1
  6. PYTHON_COMPAT=( "${_PYTHON_ALL_IMPLS[@]}" )
  7. inherit autotools-utils python-r1
  8. DESCRIPTION="Python script wrapper"
  9. HOMEPAGE="https://github.com/mgorny/python-exec/"
  10. SRC_URI="https://github.com/mgorny/${PN}/releases/download/${P}/${P}.tar.bz2"
  11. LICENSE="BSD-2"
  12. SLOT="2"
  13. KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
  14. IUSE=""
  15. RDEPEND="!<dev-python/python-exec-10000"
  16. src_configure() {
  17. local pyimpls i EPYTHON
  18. for i in "${PYTHON_COMPAT[@]}"; do
  19. python_export "${i}" EPYTHON
  20. pyimpls+=" ${EPYTHON}"
  21. done
  22. local myeconfargs=(
  23. --with-eprefix="${EPREFIX}"
  24. --with-python-impls="${pyimpls}"
  25. )
  26. autotools-utils_src_configure
  27. }