python-exec-2.1.ebuild 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. # Kids, don't do this at home!
  5. inherit python-utils-r1
  6. PYTHON_COMPAT=( "${_PYTHON_ALL_IMPLS[@]}" )
  7. # Inherited purely to have PYTHON_TARGET flags which will satisfy USE
  8. # dependencies and trigger necessary rebuilds.
  9. inherit python-r1
  10. DESCRIPTION="Python script wrapper"
  11. HOMEPAGE="https://github.com/mgorny/python-exec/"
  12. SRC_URI="https://github.com/mgorny/${PN}/releases/download/${P}/${P}.tar.bz2"
  13. LICENSE="BSD-2"
  14. SLOT="2"
  15. KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
  16. IUSE=""
  17. RDEPEND="!<dev-python/python-exec-10000
  18. !<app-eselect/eselect-python-20151117"
  19. src_configure() {
  20. local pyimpls=() i EPYTHON
  21. for i in "${PYTHON_COMPAT[@]}"; do
  22. python_export "${i}" EPYTHON
  23. pyimpls+=( "${EPYTHON}" )
  24. done
  25. local myconf=(
  26. --with-eprefix="${EPREFIX}"
  27. --with-python-impls="${pyimpls[*]}"
  28. )
  29. econf "${myconf[@]}"
  30. }