12345678910111213141516171819202122232425262728293031323334353637383940 |
- # Copyright 1999-2017 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
- EAPI=5
- # Kids, don't do this at home!
- inherit python-utils-r1
- PYTHON_COMPAT=( "${_PYTHON_ALL_IMPLS[@]}" )
- # Inherited purely to have PYTHON_TARGET flags which will satisfy USE
- # dependencies and trigger necessary rebuilds.
- inherit python-r1
- DESCRIPTION="Python script wrapper"
- HOMEPAGE="https://github.com/mgorny/python-exec/"
- SRC_URI="https://github.com/mgorny/${PN}/releases/download/${P}/${P}.tar.bz2"
- LICENSE="BSD-2"
- SLOT="2"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
- IUSE=""
- RDEPEND="!<dev-python/python-exec-10000
- !<app-eselect/eselect-python-20151117"
- src_configure() {
- local pyimpls=() i EPYTHON
- for i in "${PYTHON_COMPAT[@]}"; do
- python_export "${i}" EPYTHON
- pyimpls+=( "${EPYTHON}" )
- done
- local myconf=(
- --with-eprefix="${EPREFIX}"
- --with-python-impls="${pyimpls[*]}"
- )
- econf "${myconf[@]}"
- }
|