lua-term-0.3.ebuild 1.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit toolchain-funcs
  5. # Yes, upstream used different version numbers.
  6. # The rockspec version number is 0.3, but the version associated with
  7. # the tarball is 0.03.
  8. MY_PV=0.03
  9. DESCRIPTION="Terminal functions for Lua"
  10. HOMEPAGE="https://github.com/hoelzro/lua-term"
  11. SRC_URI="https://github.com/hoelzro/lua-term/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
  12. LICENSE="MIT"
  13. SLOT="0"
  14. KEYWORDS="amd64 ~x86"
  15. IUSE=""
  16. COMMON_DEPEND=">=dev-lang/lua-5.1:="
  17. DEPEND="${COMMON_DEPEND}
  18. virtual/pkgconfig"
  19. RDEPEND="${COMMON_DEPEND}"
  20. S="${WORKDIR}/${PN}-${MY_PV}"
  21. src_compile() {
  22. echo "$(tc-getCC) ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} -fPIC -shared \
  23. -o core.so core.c"
  24. $(tc-getCC) ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} -fPIC -shared \
  25. -o core.so core.c || die
  26. }
  27. src_install() {
  28. exeinto "$($(tc-getPKG_CONFIG) --variable INSTALL_CMOD lua)"/term
  29. doexe core.so
  30. insinto "$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD lua)"
  31. doins -r term
  32. }