lua_cliargs-3.0_p1.ebuild 896 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit toolchain-funcs
  5. # Below is the upstream package version.
  6. # The final component of the version number has been mapped to the _px
  7. # component of the version number in portage so should be kept in sync.
  8. MY_PV="3.0-1"
  9. DESCRIPTION="A command-line argument parser."
  10. HOMEPAGE="https://github.com/amireh/lua_cliargs"
  11. SRC_URI="https://github.com/amireh/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
  12. LICENSE="MIT"
  13. SLOT="0"
  14. KEYWORDS="amd64 ~x86"
  15. IUSE=""
  16. COMMON_DEPEND=">=dev-lang/lua-5.1:="
  17. DEPEND="${COMMON_DEPEND}
  18. virtual/pkgconfig"
  19. RDEPEND="${COMMON_DEPEND}"
  20. S="${WORKDIR}/${PN}-${MY_PV}"
  21. src_install() {
  22. insinto "$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD lua)"
  23. doins -r src/cliargs.lua src/cliargs
  24. dodoc README.md
  25. dodoc -r examples
  26. docinto html
  27. dodoc -r doc/*
  28. }