luacrypto-0.3.2-r1.ebuild 778 B

12345678910111213141516171819202122232425262728293031323334353637383940
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils autotools
  5. DESCRIPTION="Lua frontend to OpenSSL"
  6. HOMEPAGE="http://mkottman.github.io/luacrypto/ https://github.com/mkottman/luacrypto/"
  7. SRC_URI="https://github.com/mkottman/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="MIT"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="libressl"
  12. RDEPEND="
  13. >=dev-lang/lua-5.1:0
  14. !libressl? ( dev-libs/openssl:0 ) libressl? ( dev-libs/libressl:0 )"
  15. DEPEND="${RDEPEND}
  16. virtual/pkgconfig"
  17. src_prepare() {
  18. epatch "${FILESDIR}"/${P}-lualibdir.patch
  19. eautoreconf
  20. }
  21. src_configure() {
  22. econf --htmldir=/usr/share/doc/${PF}/html
  23. }
  24. src_test() {
  25. emake test
  26. }
  27. src_install() {
  28. default
  29. prune_libtool_files --modules
  30. }