luadoc-3.0.1.ebuild 765 B

123456789101112131415161718192021222324252627282930313233343536
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit multilib
  4. DESCRIPTION="LuaDoc is a documentation tool for Lua source code"
  5. HOMEPAGE="http://luadoc.luaforge.net/"
  6. SRC_URI="http://luaforge.net/frs/download.php/3185/${P}.tar.gz"
  7. LICENSE="MIT"
  8. SLOT="0"
  9. KEYWORDS="amd64 arm ppc ppc64 x86 ~x86-fbsd"
  10. IUSE=""
  11. DEPEND=""
  12. RDEPEND=">=dev-lang/lua-5.1.3
  13. dev-lua/luafilesystem"
  14. src_unpack() {
  15. unpack ${A}
  16. cd "${S}"
  17. sed -i \
  18. -e "s|/usr/local|\$(DESTDIR)/usr|" \
  19. -e "s|lib|$(get_libdir)|" \
  20. -e "s|lua5.1|lua|" \
  21. config || die
  22. # lua-5.1.3
  23. find . -name '*.lua' | xargs sed -i -e "s/gfind/gmatch/g" || die
  24. }
  25. src_install() {
  26. emake DESTDIR="${D}" install || die
  27. dodoc README
  28. dohtml -r doc/us/*
  29. }