async_unix-0.9.0.ebuild 754 B

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. DESCRIPTION="Jane Street Capital's asynchronous execution library (unix)"
  5. HOMEPAGE="https://github.com/janestreet/async_unix"
  6. SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  7. LICENSE="Apache-2.0"
  8. SLOT="0/${PV}"
  9. KEYWORDS="~amd64"
  10. IUSE=""
  11. RDEPEND="
  12. >=dev-lang/ocaml-4.02.0:=
  13. dev-ml/async_kernel:=
  14. dev-ml/core:=
  15. dev-ml/ppx_driver:=
  16. dev-ml/ppx_jane:=
  17. dev-ml/ocaml-migrate-parsetree:=
  18. "
  19. DEPEND="${RDEPEND} dev-ml/opam dev-ml/jbuilder"
  20. src_install() {
  21. opam-installer -i \
  22. --prefix="${ED}/usr" \
  23. --libdir="${D}/$(ocamlc -where)" \
  24. --docdir="${ED}/usr/share/doc/${PF}" \
  25. ${PN}.install || die
  26. }