bignum-0.9.0.ebuild 757 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. DESCRIPTION="Core-flavoured wrapper around zarith's arbitrary-precision rationals"
  5. HOMEPAGE="https://github.com/janestreet/bignum"
  6. SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  7. LICENSE="Apache-2.0"
  8. SLOT="0/${PV}"
  9. KEYWORDS="~amd64"
  10. IUSE=""
  11. RDEPEND="
  12. dev-lang/ocaml:=
  13. dev-ml/core_kernel:=
  14. dev-ml/core_kernel:=
  15. dev-ml/ppx_driver:=
  16. dev-ml/ppx_jane:=
  17. dev-ml/typerep:=
  18. dev-ml/zarith:=
  19. "
  20. DEPEND="${RDEPEND} dev-ml/opam dev-ml/jbuilder"
  21. src_install() {
  22. opam-installer -i \
  23. --prefix="${ED}/usr" \
  24. --libdir="${D}/$(ocamlc -where)" \
  25. --docdir="${ED}/usr/share/doc/${PF}" \
  26. ${PN}.install || die
  27. }