deriving-0.7.1.ebuild 664 B

123456789101112131415161718192021222324252627282930313233343536
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. OASIS_BUILD_TESTS=1
  5. inherit oasis
  6. DESCRIPTION="A deriving library for Ocsigen"
  7. HOMEPAGE="https://github.com/ocsigen/deriving"
  8. SRC_URI="https://github.com/ocsigen/deriving/archive/${PV}.tar.gz -> ${P}.tar.gz"
  9. LICENSE="MIT"
  10. SLOT="0/${PV}"
  11. KEYWORDS="~amd64"
  12. IUSE=""
  13. RDEPEND="
  14. >=dev-ml/type-conv-108:=
  15. dev-ml/optcomp:=
  16. dev-ml/findlib:=
  17. dev-ml/camlp4:=
  18. "
  19. DEPEND="${RDEPEND}
  20. dev-ml/oasis"
  21. DOCS=( CHANGES README.md )
  22. oasis_configure_opts="--enable-tc"
  23. OASIS_SETUP_COMMAND="./setup.exe"
  24. src_configure() {
  25. emake setup.exe
  26. oasis_src_configure
  27. }