12345678910111213141516171819202122232425262728293031323334 |
- # Copyright 1999-2017 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
- EAPI=6
- DESCRIPTION="Library for incremental computations depending only on Core_kernel"
- HOMEPAGE="https://github.com/janestreet/incremental_kernel"
- SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- LICENSE="Apache-2.0"
- SLOT="0/${PV}"
- KEYWORDS="~amd64"
- IUSE=""
- DEPEND="
- dev-lang/ocaml:=
- dev-ml/core_kernel:=
- dev-ml/ppx_driver:=
- dev-ml/ppx_jane:=
- dev-ml/ocaml-migrate-parsetree:=
- <dev-ml/ppx_jane-100
- <dev-ml/ppx_driver-100
- "
- RDEPEND="${DEPEND}"
- DEPEND="${DEPEND} dev-ml/opam dev-ml/jbuilder"
- src_install() {
- opam-installer -i \
- --prefix="${ED}/usr" \
- --libdir="${D}/$(ocamlc -where)" \
- --docdir="${ED}/usr/share/doc/${PF}" \
- ${PN}.install || die
- }
|