js-build-tools-113.33.06.ebuild 803 B

12345678910111213141516171819202122232425262728293031323334353637383940
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. OASIS_BUILD_DOCS=1
  5. OASIS_BUILD_TESTS=1
  6. inherit oasis
  7. DESCRIPTION="Collection of tools to help building Jane Street Packages"
  8. HOMEPAGE="https://github.com/janestreet/js-build-tools"
  9. SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${P}.tar.gz"
  10. LICENSE="Apache-2.0"
  11. SLOT="0/${PV}"
  12. KEYWORDS="~amd64"
  13. IUSE=""
  14. RDEPEND="dev-ml/ocamlbuild:="
  15. DEPEND="${RDEPEND} dev-ml/opam"
  16. src_configure() {
  17. emake setup.exe
  18. OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure
  19. }
  20. src_compile() {
  21. emake
  22. }
  23. src_install() {
  24. opam-installer -i \
  25. --prefix="${ED}/usr" \
  26. --libdir="${D}/$(ocamlc -where)" \
  27. --docdir="${ED}/usr/share/doc/${PF}" \
  28. ${PN}.install || die
  29. dodoc README.md
  30. }