markup-0.7.4.ebuild 768 B

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit findlib eutils
  5. DESCRIPTION="Error-recovering streaming HTML5 and XML parsers"
  6. HOMEPAGE="https://github.com/aantron/markup.ml"
  7. SRC_URI="https://github.com/aantron/markup.ml/archive/${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="BSD"
  9. SLOT="0/${PV}p1"
  10. KEYWORDS="~amd64"
  11. IUSE="doc test"
  12. DEPEND="
  13. dev-lang/ocaml:=[ocamlopt]
  14. dev-ml/lwt:=[ocamlopt]
  15. >=dev-ml/uutf-1.0:=[ocamlopt]
  16. "
  17. RDEPEND="${DEPEND}"
  18. DEPEND="${DEPEND}
  19. test? ( dev-ml/ounit )
  20. dev-ml/ocamlbuild"
  21. S="${WORKDIR}/${PN}.ml-${PV}"
  22. src_compile() {
  23. emake
  24. use doc && emake docs
  25. }
  26. src_install() {
  27. findlib_src_preinst
  28. emake ocamlfind-install
  29. dodoc README.md
  30. use doc && dohtml doc/html/*
  31. }