ocaml-mysql-1.2.1.ebuild 670 B

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit findlib eutils
  5. IUSE="+ocamlopt"
  6. DESCRIPTION="A package for ocaml that provides access to mysql databases"
  7. SRC_URI="http://ygrek.org.ua/p/release/ocaml-mysql/${P}.tar.gz"
  8. HOMEPAGE="http://ocaml-mysql.forge.ocamlcore.org/"
  9. DEPEND=">=dev-lang/ocaml-3.10.2:=[ocamlopt?]
  10. sys-libs/zlib
  11. >=virtual/mysql-4.0"
  12. RDEPEND="$DEPEND"
  13. SLOT="0/${PV}"
  14. LICENSE="LGPL-2"
  15. KEYWORDS="~amd64 ppc x86"
  16. src_compile()
  17. {
  18. emake all
  19. if use ocamlopt; then
  20. emake opt
  21. fi
  22. }
  23. src_install()
  24. {
  25. findlib_src_preinst
  26. emake install
  27. dodoc CHANGES README VERSION || die
  28. }