pgocaml-2.3.ebuild 760 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. OASIS_BUILD_DOCS=1
  5. inherit oasis
  6. DESCRIPTION="PG'OCaml is a set of OCaml bindings for the PostgreSQL database"
  7. HOMEPAGE="http://pgocaml.forge.ocamlcore.org/"
  8. SRC_URI="http://forge.ocamlcore.org/frs/download.php/1597/${P}.tgz"
  9. LICENSE="LGPL-2.1-with-linking-exception"
  10. SLOT="0/${PV}"
  11. KEYWORDS="~amd64"
  12. IUSE="+camlp4 doc"
  13. DEPEND="dev-ml/calendar:=
  14. dev-ml/csv:=
  15. dev-ml/ocaml-re:=
  16. camlp4? ( dev-ml/camlp4:= )"
  17. RDEPEND="${DEPEND}"
  18. DOCS=( "README.md" "CHANGELOG.txt"
  19. "doc/BUGS.txt" "doc/CONTRIBUTORS.txt"
  20. "doc/HOW_IT_WORKS.txt" "doc/PROFILING.txt"
  21. )
  22. src_configure() {
  23. oasis_configure_opts="$(use_enable camlp4 p4)" oasis_src_configure
  24. }