ppx_bench-0.9.0.ebuild 777 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. DESCRIPTION="Syntax extension for writing in-line benchmarks in ocaml code"
  5. HOMEPAGE="https://github.com/janestreet/ppx_bench"
  6. SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  7. LICENSE="Apache-2.0"
  8. SLOT="0/${PV}"
  9. KEYWORDS="~amd64"
  10. IUSE=""
  11. DEPEND="
  12. dev-lang/ocaml:=
  13. dev-ml/ppx_core:=
  14. dev-ml/ppx_driver:=
  15. dev-ml/ppx_inline_test:=
  16. dev-ml/ppx_metaquot:=
  17. dev-ml/ocaml-migrate-parsetree:=
  18. "
  19. RDEPEND="${DEPEND}"
  20. DEPEND="${DEPEND} dev-ml/opam dev-ml/jbuilder"
  21. src_install() {
  22. opam-installer -i \
  23. --prefix="${ED}/usr" \
  24. --libdir="${D}/$(ocamlc -where)" \
  25. --docdir="${ED}/usr/share/doc/${PF}" \
  26. ${PN}.install || die
  27. }