result-1.2.ebuild 551 B

1234567891011121314151617181920212223242526272829
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit findlib
  5. DESCRIPTION="Compat result type"
  6. HOMEPAGE="https://github.com/janestreet/result"
  7. SRC_URI="https://github.com/janestreet/result/archive/${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="BSD"
  9. SLOT="0/${PV}"
  10. KEYWORDS="~amd64 ~arm ~ppc"
  11. IUSE="+ocamlopt"
  12. RDEPEND="dev-lang/ocaml:=[ocamlopt?]"
  13. DEPEND="${RDEPEND}"
  14. src_compile() {
  15. emake byte
  16. use ocamlopt && emake native
  17. }
  18. src_install() {
  19. findlib_src_install
  20. dodoc README.md
  21. }