uuidm-0.9.6.ebuild 702 B

12345678910111213141516171819202122232425262728293031323334
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit findlib
  5. DESCRIPTION="OCaml module implementing 128 bits universally unique identifiers"
  6. HOMEPAGE="http://erratique.ch/software/uuidm"
  7. SRC_URI="http://erratique.ch/software/uuidm/releases/${P}.tbz"
  8. LICENSE="ISC"
  9. SLOT="0/${PV}"
  10. KEYWORDS="~amd64"
  11. IUSE=""
  12. RDEPEND="dev-lang/ocaml:=
  13. dev-ml/cmdliner:="
  14. DEPEND="${RDEPEND}
  15. dev-ml/opam"
  16. src_compile() {
  17. ocaml pkg/pkg.ml build || die
  18. }
  19. src_install() {
  20. opam-installer -i \
  21. --prefix="${ED}/usr" \
  22. --libdir="${D}/$(ocamlc -where)" \
  23. --docdir="${ED}/usr/share/doc/${PF}" \
  24. ${PN}.install || die
  25. dodoc CHANGES.md README.md
  26. }