PEAR-Archive_Tar-1.4.2-r2.ebuild 747 B

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. MY_PN="${PN/PEAR-/}"
  5. MY_P="${MY_PN}-${PV}"
  6. DESCRIPTION="Tar file management class"
  7. HOMEPAGE="http://pear.php.net/package/${MY_PN}"
  8. SRC_URI="http://pear.php.net/get/${MY_P}.tgz"
  9. LICENSE="BSD"
  10. SLOT="0"
  11. KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86"
  12. IUSE=""
  13. # bzip2 and zlib are needed for compressed tarballs, and there's one
  14. # call to preg_match to test paths against a pattern of files and
  15. # directories that will be ignored.
  16. RDEPEND="dev-lang/php:*[bzip2,pcre(+),zlib]"
  17. PDEPEND="dev-php/PEAR-PEAR"
  18. DEPEND=""
  19. S="${WORKDIR}/${MY_P}"
  20. src_install() {
  21. insinto /usr/share/php
  22. doins -r Archive
  23. dodoc docs/*
  24. }