SabreAMF-1.3.234_p0.ebuild 666 B

123456789101112131415161718192021222324252627282930
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="6"
  4. inherit vcs-snapshot
  5. KEYWORDS="~amd64 ~x86"
  6. DESCRIPTION="SabreAMF is a Flash Remoting server and client for PHP"
  7. HOMEPAGE="https://github.com/evert/${PN}"
  8. SRC_URI="https://github.com/evert/${PN}/archive/e5521c27e9309404d7505e1e16db843fcb2202ec.tar.gz -> ${P}.tar.gz"
  9. LICENSE="BSD"
  10. SLOT="0"
  11. IUSE="examples"
  12. DOCS=( README ChangeLog )
  13. src_install() {
  14. insinto /usr/share/php/${PN}
  15. doins -r ${PN}/*
  16. einstalldocs
  17. if use examples ; then
  18. insinto /usr/share/doc/${P}/examples
  19. docompress -x /usr/share/doc/${P}/examples
  20. doins examples/*
  21. fi
  22. }