pecl-mongodb-1.1.10.ebuild 1.0 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. PHP_EXT_NAME="mongodb"
  5. USE_PHP="php5-6 php7-0 php7-1"
  6. DOCS=( README.md )
  7. inherit php-ext-pecl-r3
  8. DESCRIPTION="MongoDB database driver for PHP"
  9. LICENSE="Apache-2.0"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. IUSE="libressl pcre sasl"
  13. RDEPEND="
  14. php_targets_php5-6? ( dev-lang/php:5.6[json,ssl,zlib] )
  15. php_targets_php7-0? ( dev-lang/php:7.0[json,ssl,zlib] )
  16. php_targets_php7-1? ( dev-lang/php:7.1[json,ssl,zlib] )
  17. >=dev-libs/libbson-1.3.3
  18. >=dev-libs/mongo-c-driver-1.3.3[sasl?,ssl]
  19. !libressl? ( dev-libs/openssl:0= )
  20. libressl? ( dev-libs/libressl:0= )
  21. pcre? ( dev-libs/libpcre )
  22. sasl? ( dev-libs/cyrus-sasl )
  23. "
  24. # pkgconfig needed if system libraries are used for bson and libmongoc
  25. DEPEND="${RDEPEND} virtual/pkgconfig"
  26. src_configure() {
  27. local PHP_EXT_ECONF_ARGS=(
  28. --enable-mongodb
  29. --with-libbson
  30. --with-libmongoc
  31. --with-pcre-dir=$(usex pcre)
  32. --with-mongodb-sasl=$(usex sasl)
  33. )
  34. php-ext-source-r3_src_configure
  35. }