pecl-mongodb-1.1.8.ebuild 977 B

123456789101112131415161718192021222324252627282930313233343536373839404142
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. PHP_EXT_NAME="mongodb"
  5. USE_PHP="php5-6 php7-0"
  6. DOCS=( README.md )
  7. inherit php-ext-pecl-r3
  8. DESCRIPTION="MongoDB database driver for PHP"
  9. LICENSE="Apache-2.0"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. IUSE="libressl pcre sasl"
  13. RDEPEND="
  14. php_targets_php5-6? ( dev-lang/php:5.6[json,ssl,zlib] )
  15. php_targets_php7-0? ( dev-lang/php:7.0[json,ssl,zlib] )
  16. >=dev-libs/libbson-1.3.3
  17. >=dev-libs/mongo-c-driver-1.3.3[sasl?,ssl]
  18. !libressl? ( dev-libs/openssl:0= )
  19. libressl? ( dev-libs/libressl:0= )
  20. pcre? ( dev-libs/libpcre )
  21. sasl? ( dev-libs/cyrus-sasl )
  22. "
  23. # pkgconfig needed if system libraries are used for bson and libmongoc
  24. DEPEND="${RDEPEND} virtual/pkgconfig"
  25. src_configure() {
  26. local PHP_EXT_ECONF_ARGS=(
  27. --enable-mongodb
  28. --with-libbson
  29. --with-libmongoc
  30. --with-pcre-dir=$(usex pcre)
  31. --with-mongodb-sasl=$(usex sasl)
  32. )
  33. php-ext-source-r3_src_configure
  34. }