phing-2.16.0.ebuild 1.5 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. DESCRIPTION="PHP project build system based on Apache Ant"
  5. HOMEPAGE="http://www.phing.info/"
  6. SRC_URI="http://www.phing.info/get/${P}.tgz"
  7. LICENSE="FDL-1.3 LGPL-2.1"
  8. SLOT="0"
  9. KEYWORDS="~amd64 ~x86"
  10. IUSE="doc examples minimal zip"
  11. RDEPEND="dev-lang/php:*[cli,xml,xslt,zip?]
  12. dev-php/symfony-yaml
  13. !minimal? (
  14. dev-php/PEAR-HTTP_Request2
  15. dev-php/PEAR-PEAR_PackageFileManager
  16. dev-php/PEAR-VersionControl_SVN
  17. dev-php/PHP_CodeCoverage
  18. dev-php/phpDocumentor
  19. dev-php/phpmd
  20. dev-php/phpunit
  21. dev-php/simpletest
  22. dev-php/xdebug
  23. )"
  24. S="${WORKDIR}"
  25. src_install() {
  26. dodoc CHANGELOG.md CREDITS.md README.md
  27. dodoc -r docs/docbook5/en/output/hlhtml
  28. use doc && dodoc -r docs/api
  29. use examples && dodoc -r docs/example
  30. # Install the executable (and the PHP file it wraps) outside of the
  31. # PHP include directory, since nobody should be including it.
  32. exeinto "/usr/share/${PN}/bin"
  33. doexe "bin/${PN}"
  34. insinto "/usr/share/${PN}/bin"
  35. doins "bin/${PN}.php"
  36. dosym "/usr/share/${PN}/bin/${PN}" "/usr/bin/${PN}"
  37. # Phing tries to get the version number from this file.
  38. insinto "/usr/share/${PN}/etc"
  39. doins etc/VERSION.TXT
  40. # The executable will only look for autoload.php in one place, so we
  41. # create an (otherwise pointless) vendor directory to house it.
  42. insinto "/usr/share/${PN}/vendor"
  43. doins "${FILESDIR}/autoload.php"
  44. # But install the library under /usr/share/php.
  45. insinto "/usr/share/php"
  46. doins -r "classes/${PN}"
  47. }