phpDocumentor-2.7.0.ebuild 652 B

1234567891011121314151617181920212223242526272829
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PHP_PEAR_URI="pear.phpdoc.org"
  5. inherit php-pear-r1
  6. DESCRIPTION="The phpDocumentor package provides automatic documenting of php api directly from the source"
  7. LICENSE="MIT"
  8. SLOT="0"
  9. KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
  10. IUSE="doc"
  11. # block old version that provides the same binary
  12. DEPEND="!dev-php/PEAR-PhpDocumentor"
  13. RDEPEND="media-gfx/graphviz
  14. dev-lang/php[iconv,intl,xmlreader,xslt]"
  15. src_install() {
  16. php-pear-r1_src_install
  17. # install manual, tutorial, reference material
  18. use doc && dodoc -r docs/*
  19. }