phpDocumentor-2.8.2.ebuild 803 B

123456789101112131415161718192021222324252627282930
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. DESCRIPTION="The phpDocumentor package provides automatic documenting of php api directly from the source"
  5. HOMEPAGE="http://phpdoc.org"
  6. SRC_URI="https://github.com/${PN}/${PN}2/releases/download/v${PV}/${PN}.phar -> ${P}.phar"
  7. LICENSE="MIT"
  8. SLOT="0"
  9. KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
  10. IUSE=""
  11. # block old version that provides the same binary
  12. DEPEND="!dev-php/PEAR-PhpDocumentor"
  13. RDEPEND="media-gfx/graphviz
  14. dev-lang/php:*[cli,iconv,intl,phar,xmlreader,xslt]"
  15. S="${WORKDIR}"
  16. src_unpack() { :; }
  17. src_install() {
  18. insinto /usr/share/php/${PN}
  19. insopts -m755
  20. newins "${DISTDIR}/${P}.phar" ${PN}.phar
  21. dosym /usr/share/php/${PN}/${PN}.phar /usr/bin/phpdoc
  22. }