psr-log-1.0.2.ebuild 533 B

12345678910111213141516171819202122232425
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. DESCRIPTION="Common interface for logging libraries"
  5. HOMEPAGE="https://github.com/php-fig/log"
  6. SRC_URI="https://github.com/php-fig/log/archive/${PV}.tar.gz -> ${P}.tar.gz"
  7. LICENSE="MIT"
  8. SLOT="0"
  9. KEYWORDS="~amd64 ~x86"
  10. RDEPEND="
  11. dev-lang/php:*
  12. dev-php/fedora-autoloader"
  13. S="${WORKDIR}/log-${PV}"
  14. src_install() {
  15. insinto "/usr/share/php/Psr/Log"
  16. doins -r Psr/Log/. "${FILESDIR}"/autoload.php
  17. dodoc README.md
  18. }