sebastian-resource-operations-1.0.0.ebuild 647 B

12345678910111213141516171819202122232425262728
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. MY_PN="${PN/sebastian-//}"
  5. DESCRIPTION="Provides a list of PHP built-in functions that operate on resources"
  6. HOMEPAGE="http://phpunit.de"
  7. SRC_URI="https://github.com/sebastianbergmann/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="BSD"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
  11. IUSE=""
  12. S="${WORKDIR}/${MY_PN}-${PV}"
  13. RDEPEND="dev-php/fedora-autoloader
  14. >=dev-lang/php-5.6:*
  15. "
  16. src_install() {
  17. insinto /usr/share/php/SebastianBergmann/ResourceOperations
  18. doins -r src/*
  19. doins "${FILESDIR}/autoload.php"
  20. }