gauche-qdbm-0.2-r1.ebuild 580 B

1234567891011121314151617181920212223242526272829
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="4"
  4. inherit autotools eutils
  5. MY_P="${P/g/G}"
  6. DESCRIPTION="QDBM binding for Gauche"
  7. HOMEPAGE="http://sourceforge.jp/projects/gauche/"
  8. SRC_URI="mirror://sourceforge.jp/gauche/6988/${MY_P}.tar.gz"
  9. LICENSE="BSD"
  10. SLOT="0"
  11. KEYWORDS="~sparc x86"
  12. IUSE=""
  13. RDEPEND="dev-scheme/gauche
  14. dev-db/qdbm"
  15. DEPEND="${RDEPEND}"
  16. S="${WORKDIR}/${MY_P}"
  17. src_prepare() {
  18. epatch "${FILESDIR}"/${P}-gauche-package.diff
  19. epatch "${FILESDIR}"/${P}-undefined-reference.diff
  20. eautoreconf
  21. }