guile-2.0.14.ebuild 2.0 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit flag-o-matic autotools
  5. DESCRIPTION="GNU Ubiquitous Intelligent Language for Extensions"
  6. HOMEPAGE="https://www.gnu.org/software/guile/"
  7. SRC_URI="mirror://gnu/guile/${P}.tar.gz"
  8. KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
  9. LICENSE="LGPL-3+"
  10. IUSE="debug debug-malloc +deprecated +networking +nls +regex +threads" # upstream recommended +networking +nls
  11. # emacs useflag removal not working
  12. RDEPEND="
  13. >=dev-libs/boehm-gc-7.0[threads?]
  14. dev-libs/gmp:=
  15. virtual/libffi
  16. dev-libs/libltdl:=
  17. dev-libs/libunistring:0=
  18. sys-devel/libtool
  19. sys-libs/ncurses:0=
  20. sys-libs/readline:0="
  21. DEPEND="${RDEPEND}
  22. virtual/pkgconfig
  23. sys-apps/texinfo
  24. sys-devel/gettext"
  25. SLOT="12/22" # subslot is soname version
  26. MAJOR="2.0"
  27. DOCS=( GUILE-VERSION HACKING README )
  28. src_prepare() {
  29. default
  30. eautoreconf
  31. }
  32. src_configure() {
  33. # see bug #178499
  34. filter-flags -ftree-vectorize
  35. econf \
  36. --disable-error-on-warning \
  37. --disable-rpath \
  38. --enable-posix \
  39. --without-libgmp-prefix \
  40. --without-libiconv-prefix \
  41. --without-libintl-prefix \
  42. --without-libltdl-prefix \
  43. --without-libreadline-prefix \
  44. --without-libunistring-prefix \
  45. $(use_enable debug guile-debug) \
  46. $(use_enable debug-malloc) \
  47. $(use_enable deprecated) \
  48. $(use_enable networking) \
  49. $(use_enable nls) \
  50. $(use_enable regex) \
  51. $(use_with threads)
  52. }
  53. src_install() {
  54. default
  55. # From Novell
  56. # https://bugzilla.novell.com/show_bug.cgi?id=874028#c0
  57. dodir /usr/share/gdb/auto-load/$(get_libdir)
  58. mv "${ED}"/usr/$(get_libdir)/libguile-*-gdb.scm "${ED}"/usr/share/gdb/auto-load/$(get_libdir) || die
  59. # necessary for registering slib, see bug 206896
  60. keepdir /usr/share/guile/site
  61. # Dark magic necessary for some deps
  62. dosym libguile-2.0.so /usr/$(get_libdir)/libguile.so
  63. }