stklos-1.10.ebuild 933 B

123456789101112131415161718192021222324252627282930313233343536
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="3"
  4. DESCRIPTION="fast and light Scheme implementation"
  5. HOMEPAGE="http://www.stklos.net"
  6. SRC_URI="http://www.stklos.net/download/${P}.tar.gz"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. KEYWORDS="~amd64 ~x86"
  10. IUSE="threads"
  11. DEPEND="dev-libs/gmp dev-libs/libpcre virtual/libffi dev-libs/boehm-gc[threads?]"
  12. RDEPEND="${DEPEND}"
  13. #parallel build failure reported upstream
  14. MAKEOPTS=-j1
  15. src_prepare() {
  16. # kill bundled libs
  17. rm -rf "${S}"/{ffi,gc,gmp,pcre}
  18. }
  19. src_configure() {
  20. econf --enable-threads=$(if use threads; then echo pthreads; else echo none; fi) \
  21. --without-gmp-light --without-provided-gc \
  22. --without-provided-regexp --without-provided-ffi
  23. }
  24. src_install() {
  25. emake DESTDIR="${D}" install || die "Install failed"
  26. dodoc AUTHORS ChangeLog NEWS PACKAGES-USED PORTING-NOTES README SUPPORTED-SRFIS \
  27. || die "dodocs failed"
  28. }