texlive-metapost-2016.ebuild 2.1 KB

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. TEXLIVE_MODULE_CONTENTS="automata bbcard blockdraw_mp bpolynomial cmarrows drv dviincl emp epsincl expressg exteps featpost feynmp-auto garrigues gmp hatching latexmp mcf2graph metago metaobj metaplot metapost metauml mfpic mfpic4ode mp3d mparrows mpattern mpcolornames mpgraphics piechartmp repere roex roundrect shapes slideshow splines suanpan textpath threeddice collection-metapost
  5. "
  6. TEXLIVE_MODULE_DOC_CONTENTS="automata.doc bbcard.doc blockdraw_mp.doc bpolynomial.doc cmarrows.doc drv.doc dviincl.doc emp.doc epsincl.doc expressg.doc exteps.doc featpost.doc feynmp-auto.doc garrigues.doc gmp.doc hatching.doc latexmp.doc mcf2graph.doc metago.doc metaobj.doc metaplot.doc metapost.doc metauml.doc mfpic.doc mfpic4ode.doc mp3d.doc mparrows.doc mpattern.doc mpcolornames.doc mpgraphics.doc piechartmp.doc repere.doc roundrect.doc shapes.doc slideshow.doc splines.doc suanpan.doc textpath.doc threeddice.doc "
  7. TEXLIVE_MODULE_SRC_CONTENTS="emp.source expressg.source feynmp-auto.source gmp.source mfpic.source mfpic4ode.source mpcolornames.source mpgraphics.source roex.source roundrect.source shapes.source splines.source "
  8. inherit texlive-module
  9. DESCRIPTION="TeXLive MetaPost and Metafont packages"
  10. LICENSE=" BSD GPL-1 GPL-2 LGPL-2 LPPL-1.3 public-domain TeX-other-free "
  11. SLOT="0"
  12. KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~s390 ~sh ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
  13. IUSE=""
  14. DEPEND=">=dev-texlive/texlive-basic-2016
  15. "
  16. RDEPEND="${DEPEND} "
  17. # This small hack is needed in order to have a sane upgrade path:
  18. # the new TeX Live 2009 metapost produces this file but it is not recorded in
  19. # any package; when running fmtutil (like texmf-update does) this file will be
  20. # created and cause collisions.
  21. pkg_setup() {
  22. if [ -f "${ROOT%/}${EPREFIX}/var/lib/texmf/web2c/metapost/mplib-luatex.mem" ]; then
  23. einfo "Removing ${ROOT%/}${EPREFIX}/var/lib/texmf/web2c/metapost/mplib-luatex.mem"
  24. rm -f "${ROOT%/}${EPREFIX}/var/lib/texmf/web2c/metapost/mplib-luatex.mem"
  25. fi
  26. }