cvs-fast-export-1.26.ebuild 794 B

12345678910111213141516171819202122232425262728293031323334353637383940
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit toolchain-funcs
  5. DESCRIPTION="fast-export history from a CVS repository or RCS collection"
  6. HOMEPAGE="http://www.catb.org/~esr/cvs-fast-export/"
  7. SRC_URI="http://www.catb.org/~esr/${PN}/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE=""
  12. RDEPEND=""
  13. DEPEND="${RDEPEND}
  14. app-text/asciidoc"
  15. RESTRICT=test # upstream does not ship them in tarball
  16. src_prepare() {
  17. tc-export CC
  18. export prefix=/usr
  19. # respect CC, CFLAGS and LDFLAGS. don't install cvssync
  20. sed \
  21. -e 's/cc /$(CC) $(LDFLAGS) /' \
  22. -e 's/^CFLAGS += -O/#&/' \
  23. -e 's/CFLAGS=/CFLAGS+=/' \
  24. -e 's/$(INSTALL).*cvssync/#&/g' \
  25. -i Makefile || die
  26. }
  27. src_install() {
  28. default
  29. dodoc README
  30. }