cvsps-3.13-r1.ebuild 1.0 KB

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils toolchain-funcs
  5. DESCRIPTION="Generates patchset information from a CVS repository (supports fast-import)"
  6. HOMEPAGE="http://www.catb.org/~esr/cvsps/"
  7. SRC_URI="http://www.catb.org/~esr/${PN}/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="3"
  10. KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
  11. IUSE=""
  12. RDEPEND="sys-libs/zlib"
  13. DEPEND="${RDEPEND}
  14. app-text/asciidoc"
  15. RESTRICT=test # upstream does not ship tests
  16. src_prepare() {
  17. local gentoo_name=${PN}-3
  18. epatch "${FILESDIR}"/${P}-make.patch
  19. mv ${PN}.asc ${gentoo_name}.asc || die
  20. sed -i "s/${PN}/${gentoo_name}/g" ${gentoo_name}.asc || die
  21. sed -i "s/PROG = cvsps/PROG = ${gentoo_name}/" Makefile || die
  22. tc-export CC
  23. export prefix="${EPREFIX}"/usr
  24. }
  25. src_install() {
  26. default
  27. dodoc README
  28. }