darcs-2.12.4.ebuild 4.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. # ebuild generated by hackport 0.5.9999
  5. #hackport: flags: +library,+executable,-hpc,-warn-as-error,+pkgconfig,-rts,-static,-optimize,hashed-storage-diff:diff,+http
  6. CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
  7. inherit haskell-cabal
  8. DESCRIPTION="a distributed, interactive, smart revision control system"
  9. HOMEPAGE="http://darcs.net/"
  10. SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
  11. LICENSE="GPL-2"
  12. SLOT="0/${PV}"
  13. KEYWORDS="~amd64 ~x86"
  14. IUSE="+curl +network-uri +terminfo +threaded"
  15. RDEPEND=">=dev-haskell/async-2.0.1.4:=[profile?] <dev-haskell/async-2.2:=[profile?]
  16. >=dev-haskell/attoparsec-0.11:=[profile?] <dev-haskell/attoparsec-0.14:=[profile?]
  17. >=dev-haskell/base16-bytestring-0.1:=[profile?] <dev-haskell/base16-bytestring-0.2:=[profile?]
  18. >=dev-haskell/cryptohash-0.4:=[profile?] <dev-haskell/cryptohash-0.12:=[profile?]
  19. >=dev-haskell/data-ordlist-0.4:=[profile?] <dev-haskell/data-ordlist-0.5:=[profile?]
  20. >=dev-haskell/fgl-5.5.0.1:=[profile?] <dev-haskell/fgl-5.6:=[profile?]
  21. >=dev-haskell/graphviz-2999.17.0.1:=[profile?] <dev-haskell/graphviz-2999.19:=[profile?]
  22. >=dev-haskell/hashable-1.1.2.5:=[profile?] <dev-haskell/hashable-1.3:=[profile?]
  23. >=dev-haskell/haskeline-0.6.3:=[profile?] <dev-haskell/haskeline-0.8:=[profile?]
  24. >=dev-haskell/html-1.0.1.2:=[profile?] <dev-haskell/html-1.1:=[profile?]
  25. >=dev-haskell/http-4000.2.8:=[profile?] <dev-haskell/http-4000.4:=[profile?]
  26. >=dev-haskell/mmap-0.5:=[profile?] <dev-haskell/mmap-0.6:=[profile?]
  27. >=dev-haskell/mtl-2.1.2:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
  28. >=dev-haskell/old-time-1.1:=[profile?] <dev-haskell/old-time-1.2:=[profile?]
  29. >=dev-haskell/parsec-3.1:=[profile?] <dev-haskell/parsec-3.2:=[profile?]
  30. >=dev-haskell/random-1.0.1.1:=[profile?] <dev-haskell/random-1.2:=[profile?]
  31. >=dev-haskell/regex-applicative-0.2:=[profile?] <dev-haskell/regex-applicative-0.4:=[profile?]
  32. >=dev-haskell/regex-compat-tdfa-0.95.1:=[profile?] <dev-haskell/regex-compat-tdfa-0.96:=[profile?]
  33. >=dev-haskell/sandi-0.4:=[profile?] <dev-haskell/sandi-0.5:=[profile?]
  34. >=dev-haskell/tar-0.4:=[profile?] <dev-haskell/tar-0.6:=[profile?]
  35. >=dev-haskell/text-1.2.1.3:=[profile?] <dev-haskell/text-1.3:=[profile?]
  36. >=dev-haskell/transformers-compat-0.4:=[profile?] <dev-haskell/transformers-compat-0.6:=[profile?]
  37. >=dev-haskell/unix-compat-0.1.2:=[profile?] <dev-haskell/unix-compat-0.5:=[profile?]
  38. >=dev-haskell/utf8-string-0.3.6:=[profile?] <dev-haskell/utf8-string-1.1:=[profile?]
  39. >=dev-haskell/vector-0.10.0.1:=[profile?] <dev-haskell/vector-0.12:=[profile?]
  40. >=dev-haskell/zip-archive-0.2.3:=[profile?] <dev-haskell/zip-archive-0.4:=[profile?]
  41. >=dev-haskell/zlib-0.5.4.1:=[profile?] <dev-haskell/zlib-0.7.0.0:=[profile?]
  42. >=dev-lang/ghc-7.10.1:=
  43. curl? ( net-misc/curl )
  44. network-uri? ( >=dev-haskell/network-2.6:=[profile?] <dev-haskell/network-2.7:=[profile?]
  45. >=dev-haskell/network-uri-2.6:=[profile?] <dev-haskell/network-uri-2.7:=[profile?] )
  46. !network-uri? ( >=dev-haskell/network-2.4.1.2:=[profile?] <dev-haskell/network-2.6:=[profile?] )
  47. terminfo? ( >=dev-haskell/terminfo-0.3:=[profile?] <dev-haskell/terminfo-0.5:=[profile?] )
  48. "
  49. DEPEND="${RDEPEND}
  50. >=dev-haskell/cabal-1.22.2.0
  51. test? ( >=dev-haskell/cmdargs-0.10 <dev-haskell/cmdargs-0.11
  52. >=dev-haskell/findbin-0.0 <dev-haskell/findbin-0.1
  53. >=dev-haskell/hunit-1.2.5.2 <dev-haskell/hunit-1.4
  54. >=dev-haskell/quickcheck-2.6 <dev-haskell/quickcheck-2.10
  55. >=dev-haskell/shelly-1.6.2 <dev-haskell/shelly-1.7
  56. >=dev-haskell/split-0.2.2 <dev-haskell/split-0.3
  57. >=dev-haskell/test-framework-0.4.0 <dev-haskell/test-framework-0.9
  58. >=dev-haskell/test-framework-hunit-0.2.2 <dev-haskell/test-framework-hunit-0.4
  59. >=dev-haskell/test-framework-quickcheck2-0.3 <dev-haskell/test-framework-quickcheck2-0.4 )
  60. curl? ( virtual/pkgconfig )
  61. "
  62. src_configure() {
  63. haskell-cabal_src_configure \
  64. $(cabal_flag curl curl) \
  65. --flag=executable \
  66. --flag=-hpc \
  67. --flag=http \
  68. --flag=library \
  69. $(cabal_flag network-uri network-uri) \
  70. --flag=-optimize \
  71. --flag=pkgconfig \
  72. --flag=-rts \
  73. --flag=-static \
  74. $(cabal_flag terminfo terminfo) \
  75. $(cabal_flag threaded threaded) \
  76. --flag=-warn-as-error
  77. }
  78. src_install() {
  79. haskell-cabal_src_install
  80. # fixup perms in such an an awkward way
  81. mv "${ED}/usr/share/man/man1/darcs.1" "${S}/darcs.1" || die "darcs.1 not found"
  82. doman "${S}/darcs.1"
  83. }