giggle-0.7-r1.ebuild 926 B

12345678910111213141516171819202122232425262728293031323334353637383940414243444546
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. GCONF_DEBUG="no"
  5. GNOME2_LA_PUNT="yes"
  6. inherit gnome2 eutils
  7. DESCRIPTION="GTK+ Frontend for GIT"
  8. HOMEPAGE="https://wiki.gnome.org/Apps/giggle"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
  12. IUSE="eds"
  13. RDEPEND="
  14. >=dev-vcs/git-1.5
  15. >=dev-libs/glib-2.30:2
  16. >=x11-libs/gtk+-3.3.12:3
  17. >=x11-libs/gtksourceview-3.0:3.0
  18. >=x11-libs/gdk-pixbuf-2.22.0
  19. eds? ( gnome-extra/evolution-data-server )
  20. >=x11-libs/vte-0.28:2.90
  21. "
  22. DEPEND="${RDEPEND}
  23. gnome-base/gnome-common
  24. sys-devel/gettext
  25. app-text/yelp-tools
  26. virtual/pkgconfig
  27. >=dev-util/intltool-0.35
  28. >=sys-devel/autoconf-2.64
  29. >=sys-devel/libtool-2
  30. "
  31. src_prepare() {
  32. epatch "${FILESDIR}/${PN}-0.6.2-gtksourceview-3.8.0.patch"
  33. gnome2_src_prepare
  34. }
  35. src_configure() {
  36. gnome2_src_configure \
  37. $(use_enable eds evolution-data-server)
  38. }