git-annex-6.20161031.ebuild 4.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. # ebuild generated by hackport 0.4.7.9999
  5. #hackport: flags: -production,-android,-androidsplice,-testsuite
  6. CABAL_FEATURES="bin"
  7. inherit haskell-cabal bash-completion-r1
  8. DESCRIPTION="manage files with git, without checking their contents into git"
  9. HOMEPAGE="http://git-annex.branchable.com/"
  10. SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
  11. RESTRICT="test"
  12. LICENSE="GPL-3"
  13. SLOT="0"
  14. KEYWORDS="~amd64 ~x86 ~amd64-linux"
  15. IUSE="+assistant benchmark +concurrentoutput +cryptonite doc +dbus +magicmime +network-uri +pairing s3 +torrentparser +webapp +webdav +xmpp"
  16. RDEPEND="dev-haskell/aeson:=
  17. dev-haskell/async:=
  18. dev-haskell/bloomfilter:=
  19. dev-haskell/case-insensitive:=
  20. dev-haskell/data-default:=
  21. dev-haskell/disk-free-space:=
  22. dev-haskell/dlist:=
  23. dev-haskell/edit-distance:=
  24. dev-haskell/esqueleto:=
  25. >=dev-haskell/exceptions-0.6:=
  26. dev-haskell/feed:=
  27. dev-haskell/hslogger:=
  28. dev-haskell/http-client:=
  29. dev-haskell/http-conduit:=
  30. dev-haskell/http-types:=
  31. dev-haskell/ifelse:=
  32. dev-haskell/missingh:=
  33. dev-haskell/monad-control:=
  34. dev-haskell/monad-logger:=
  35. >=dev-haskell/mtl-2:=
  36. dev-haskell/old-locale:=
  37. >=dev-haskell/optparse-applicative-0.11.0:=
  38. dev-haskell/persistent:=
  39. dev-haskell/persistent-sqlite:=
  40. dev-haskell/persistent-template:=
  41. >=dev-haskell/quickcheck-2.1:2=
  42. dev-haskell/random:=
  43. dev-haskell/regex-tdfa:=
  44. dev-haskell/resourcet:=
  45. dev-haskell/safesemaphore:=
  46. dev-haskell/sandi:=
  47. >=dev-haskell/stm-2.3:=
  48. dev-haskell/text:=
  49. dev-haskell/transformers:=
  50. dev-haskell/unix-compat:=
  51. dev-haskell/unordered-containers:=
  52. dev-haskell/utf8-string:=
  53. >=dev-haskell/uuid-1.2.6:=
  54. >=dev-lang/ghc-7.6.1:=
  55. assistant? ( dev-haskell/dns:=
  56. dev-haskell/hinotify:=
  57. dev-haskell/mountpoints:=
  58. sys-process/lsof )
  59. benchmark? ( dev-haskell/criterion:= )
  60. concurrentoutput? ( >=dev-haskell/concurrent-output-1.6:= )
  61. cryptonite? ( dev-haskell/cryptonite:= )
  62. !cryptonite? ( >=dev-haskell/cryptohash-0.11.0:= )
  63. dbus? ( >=dev-haskell/dbus-0.10.7:=
  64. >=dev-haskell/fdo-notify-0.3:= )
  65. magicmime? ( dev-haskell/magic:= )
  66. network-uri? ( >=dev-haskell/network-2.6:=
  67. >=dev-haskell/network-uri-2.6:= )
  68. !network-uri? ( >=dev-haskell/network-2.4:= <dev-haskell/network-2.6:= )
  69. pairing? ( dev-haskell/network-info:=
  70. dev-haskell/network-multicast:= )
  71. s3? ( >=dev-haskell/aws-0.9.2:=
  72. dev-haskell/conduit:=
  73. dev-haskell/conduit-extra:= )
  74. torrentparser? ( >=dev-haskell/torrent-10000.0.0:= )
  75. webapp? ( dev-haskell/blaze-builder:=
  76. dev-haskell/byteable:=
  77. dev-haskell/clientsession:=
  78. dev-haskell/crypto-api:=
  79. >=dev-haskell/path-pieces-0.1.4:=
  80. dev-haskell/securemem:=
  81. >=dev-haskell/shakespeare-2.0.0:=
  82. dev-haskell/wai:=
  83. dev-haskell/wai-extra:=
  84. >=dev-haskell/warp-3.0.0.5:=
  85. >=dev-haskell/warp-tls-1.4:=
  86. >=dev-haskell/yesod-1.2.6:=
  87. >=dev-haskell/yesod-core-1.2.19:=
  88. >=dev-haskell/yesod-default-1.2.0:=
  89. >=dev-haskell/yesod-form-1.3.15:=
  90. >=dev-haskell/yesod-static-1.2.4:= )
  91. webdav? ( >=dev-haskell/dav-1.0:= )
  92. xmpp? ( >=dev-haskell/gnutls-0.1.4:=
  93. dev-haskell/network-protocol-xmpp:=
  94. dev-haskell/xml-types:= )
  95. "
  96. # not generated by hackport:
  97. RDEPEND="${RDEPEND}
  98. dev-vcs/git
  99. "
  100. DEPEND="${RDEPEND}
  101. >=dev-haskell/cabal-1.16.0
  102. "
  103. # not generated by hackport:
  104. DEPEND="${DEPEND}
  105. dev-lang/perl
  106. doc? ( www-apps/ikiwiki net-misc/rsync )
  107. "
  108. PATCHES=(
  109. "${FILESDIR}"/${PN}-6.20160114-QC-2.8.2.patch
  110. )
  111. src_prepare() {
  112. default
  113. cabal_chdeps \
  114. 'http-conduit (<2.2.0)' 'http-conduit' \
  115. 'persistent (< 2.5)' 'persistent'
  116. }
  117. src_configure() {
  118. haskell-cabal_src_configure \
  119. --flag=-android \
  120. --flag=-androidsplice \
  121. $(cabal_flag assistant assistant) \
  122. $(cabal_flag benchmark benchmark) \
  123. $(cabal_flag concurrentoutput concurrentoutput) \
  124. $(cabal_flag cryptonite cryptonite) \
  125. $(cabal_flag dbus dbus) \
  126. $(cabal_flag magicmime magicmime) \
  127. $(cabal_flag network-uri network-uri) \
  128. $(cabal_flag pairing pairing) \
  129. --flag=-production \
  130. $(cabal_flag s3 s3) \
  131. --flag=-testsuite \
  132. $(cabal_flag torrentparser torrentparser) \
  133. $(cabal_flag webapp webapp) \
  134. $(cabal_flag webdav webdav) \
  135. $(cabal_flag xmpp xmpp)
  136. }
  137. src_test() {
  138. if use webapp; then
  139. export GIT_CONFIG=${T}/temp-git-config
  140. git config user.email "git@src_test"
  141. git config user.name "Mr. ${P} The Test"
  142. emake test
  143. fi
  144. }
  145. src_install() {
  146. haskell-cabal_src_install
  147. newbashcomp "${FILESDIR}"/${PN}.bash ${PN}
  148. dodoc CHANGELOG README
  149. if use webapp ; then
  150. doicon "${FILESDIR}"/${PN}.xpm
  151. make_desktop_entry "${PN} webapp" "git-annex" ${PN}.xpm "Office"
  152. fi
  153. }