gitg-3.22.0.ebuild 1.9 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. GNOME2_LA_PUNT="yes"
  5. PYTHON_COMPAT=( python{3_4,3_5} )
  6. VALA_MIN_API_VERSION="0.32" # Needed when gtk+-3.20 is found
  7. inherit gnome2 pax-utils python-r1 vala
  8. DESCRIPTION="git repository viewer for GNOME"
  9. HOMEPAGE="https://wiki.gnome.org/Apps/Gitg"
  10. LICENSE="|| ( GPL-2 GPL-3 )"
  11. SLOT="0"
  12. KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
  13. IUSE="glade +python"
  14. REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
  15. # test if unbundling of libgd is possible
  16. # Currently it seems not to be (unstable API/ABI)
  17. RDEPEND="
  18. app-crypt/libsecret
  19. dev-libs/libgee:0.8[introspection]
  20. >=app-text/gtkspell-3.0.3:3
  21. >=dev-libs/glib-2.38:2[dbus]
  22. >=dev-libs/gobject-introspection-0.10.1:=
  23. dev-libs/libgit2:=[threads]
  24. >=dev-libs/libgit2-glib-0.24.4[ssh]
  25. <dev-libs/libgit2-glib-0.25.0
  26. >=dev-libs/libpeas-1.5.0[gtk]
  27. >=dev-libs/libxml2-2.9.0:2
  28. net-libs/libsoup:2.4
  29. >=gnome-base/gsettings-desktop-schemas-0.1.1
  30. >=x11-libs/gtk+-3.20.0:3
  31. >=x11-libs/gtksourceview-3.10:3.0
  32. x11-themes/adwaita-icon-theme
  33. glade? ( >=dev-util/glade-3.2:3.10 )
  34. python? (
  35. ${PYTHON_DEPS}
  36. dev-python/pygobject:3[${PYTHON_USEDEP}]
  37. )
  38. "
  39. DEPEND="${RDEPEND}
  40. $(vala_depend)
  41. >=dev-libs/libgit2-glib-0.24.4[vala]
  42. >=dev-util/intltool-0.40
  43. gnome-base/gnome-common
  44. >=sys-devel/gettext-0.17
  45. virtual/pkgconfig
  46. "
  47. pkg_setup() {
  48. use python && [[ ${MERGE_TYPE} != binary ]] && python_setup
  49. }
  50. src_prepare() {
  51. gnome2_src_prepare
  52. vala_src_prepare
  53. }
  54. src_configure() {
  55. gnome2_src_configure \
  56. --disable-static \
  57. --disable-deprecations \
  58. $(use_enable glade glade-catalog) \
  59. $(use_enable python)
  60. }
  61. src_install() {
  62. # -j1: bug #???
  63. gnome2_src_install -j1
  64. if use python ; then
  65. install_gi_override() {
  66. python_moduleinto "$(python_get_sitedir)/gi/overrides"
  67. python_domodule "${S}"/libgitg-ext/GitgExt.py
  68. }
  69. python_foreach_impl install_gi_override
  70. fi
  71. }