svnmailer-1.0.9-r1.ebuild 760 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python2_7 )
  5. DISTUTILS_SINGLE_IMPL=1
  6. inherit distutils-r1
  7. DESCRIPTION="A subversion commit notifier written in Python"
  8. HOMEPAGE="http://opensource.perlig.de/svnmailer/"
  9. SRC_URI="http://storage.perlig.de/svnmailer/${P}.tar.bz2"
  10. LICENSE="Apache-2.0"
  11. SLOT="0"
  12. KEYWORDS="~amd64 ~x86"
  13. IUSE=""
  14. DEPEND="${DEPEND}
  15. dev-vcs/subversion[python,${PYTHON_USEDEP}]
  16. virtual/mta"
  17. RDEPEND="${DEPEND}"
  18. pkg_setup() {
  19. python-single-r1_pkg_setup
  20. }
  21. python_prepare_all() {
  22. sed -i -e "s:man/man1:share/&:" setup.py || die
  23. distutils-r1_python_prepare_all
  24. }
  25. python_install_all() {
  26. local HTML_DOCS=( docs/. )
  27. distutils-r1_python_install_all
  28. }