rafkill-1.2.3.ebuild 843 B

12345678910111213141516171819202122232425262728293031323334353637383940414243
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils scons-utils games
  5. DESCRIPTION="space shoot-em-up game"
  6. HOMEPAGE="http://raptorv2.sourceforge.net/"
  7. SRC_URI="mirror://sourceforge/raptorv2/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ppc x86"
  11. IUSE=""
  12. DEPEND="<media-libs/allegro-5
  13. media-libs/aldumb"
  14. RDEPEND=${DEPEND}
  15. src_prepare() {
  16. rm -f {data,music}/.sconsign
  17. epatch \
  18. "${FILESDIR}"/${P}-build.patch \
  19. "${FILESDIR}"/${P}-gcc43.patch \
  20. "${FILESDIR}"/${P}-gcc47.patch \
  21. "${FILESDIR}"/${P}-ldflags.patch
  22. sed -i \
  23. -e "/^#define INSTALL_DIR/s:\.:${GAMES_DATADIR}:" \
  24. src/defs.cpp || die
  25. }
  26. src_compile() {
  27. escons
  28. }
  29. src_install() {
  30. dogamesbin ${PN}
  31. insinto "${GAMES_DATADIR}"/${PN}
  32. doins -r data music
  33. dodoc README
  34. prepgamesdirs
  35. }