gtkboard-0.11_pre0-r1.ebuild 976 B

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit eutils
  5. MY_P=${P/_}
  6. DESCRIPTION="Board games system"
  7. HOMEPAGE="http://gtkboard.sourceforge.net/"
  8. SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~ppc ~x86"
  12. IUSE="gnome"
  13. RDEPEND="x11-libs/gtk+:2
  14. media-libs/libsdl:0[sound]
  15. media-libs/sdl-mixer[vorbis]
  16. gnome? ( gnome-base/libgnomeui )"
  17. DEPEND="${RDEPEND}
  18. virtual/pkgconfig"
  19. S=${WORKDIR}/${MY_P}
  20. PATCHES=(
  21. "${FILESDIR}"/${P}-gcc41.patch
  22. "${FILESDIR}"/${P}-gcc45.patch
  23. )
  24. src_prepare() {
  25. default
  26. sed -i -e "/^LIBS/s:@LIBS@:@LIBS@ -lgmodule-2.0 -lm:" \
  27. src/Makefile.in
  28. }
  29. src_configure() {
  30. econf \
  31. --disable-dependency-tracking \
  32. --enable-gtk2 \
  33. --enable-sdl \
  34. $(use_enable gnome)
  35. }
  36. src_install() {
  37. emake DESTDIR="${D}" install
  38. doicon pixmaps/${PN}.png
  39. make_desktop_entry ${PN} Gtkboard
  40. dodoc AUTHORS ChangeLog TODO doc/index.html
  41. }