mt_gtk_client-0.1.98.ebuild 850 B

12345678910111213141516171819202122232425262728293031323334353637383940
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit games eutils
  5. DESCRIPTION="client for the french tarot game maitretarot"
  6. HOMEPAGE="http://www.nongnu.org/maitretarot/"
  7. SRC_URI="https://savannah.nongnu.org/download/maitretarot/${PN}.pkg/${PV}/${P}.tar.bz2"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE="gnome"
  12. DEPEND="dev-libs/glib:2
  13. dev-libs/libxml2
  14. dev-games/libmaitretarot
  15. dev-games/libmt_client
  16. gnome-base/libgnomeui
  17. x11-libs/gtk+:2"
  18. RDEPEND="${DEPEND}
  19. dev-games/cardpics"
  20. src_prepare() {
  21. epatch "${FILESDIR}"/${P}-formatsecurity.patch
  22. }
  23. src_configure() {
  24. egamesconf $(use_enable gnome gnome2)
  25. }
  26. src_install() {
  27. default
  28. if [[ -d "${D}"/${GAMES_DATADIR}/locale ]] ; then
  29. mv "${D}"/${GAMES_DATADIR}/locale "${D}"/usr/share/ || die
  30. fi
  31. prepgamesdirs
  32. }