sirius-0.8.0-r1.ebuild 766 B

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit autotools
  5. DESCRIPTION="A program for playing the game of othello/reversi"
  6. HOMEPAGE="http://sirius.bitvis.nu/"
  7. SRC_URI="http://sirius.bitvis.nu/files/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE="nls"
  12. RDEPEND="
  13. gnome-base/gconf:2
  14. gnome-base/libgnomecanvas
  15. gnome-base/libgnomeui
  16. x11-libs/gtk+:2
  17. nls? ( virtual/libintl )"
  18. DEPEND="${RDEPEND}
  19. nls? ( sys-devel/gettext )"
  20. PATCHES=(
  21. "${FILESDIR}"/${P}-format.patch
  22. "${FILESDIR}"/${P}-fix-desktop-file.patch
  23. "${FILESDIR}"/${P}-fix-build-system.patch
  24. )
  25. src_prepare() {
  26. default
  27. mv configure.{in,ac} || die
  28. eautoreconf
  29. }
  30. src_configure() {
  31. econf $(use_enable nls)
  32. }