xfreecell-1.0.5b-r1.ebuild 884 B

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit eutils
  5. DESCRIPTION="A freecell game for X"
  6. HOMEPAGE="http://www2.giganet.net/~nakayama/"
  7. SRC_URI="http://www2.giganet.net/~nakayama/${P}.tgz
  8. http://www2.giganet.net/~nakayama/MSNumbers.gz"
  9. LICENSE="HPND"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
  12. IUSE=""
  13. RDEPEND="media-fonts/font-misc-misc
  14. x11-libs/libXext"
  15. DEPEND="${RDEPEND}
  16. x11-proto/xextproto"
  17. S=${WORKDIR}/${PN}
  18. PATCHES=(
  19. "${FILESDIR}"/${P}-gentoo.patch
  20. "${FILESDIR}"/${P}-gcc43.patch
  21. )
  22. src_install() {
  23. dobin xfreecell
  24. insinto /usr/share/${PN}
  25. doins "${WORKDIR}"/MSNumbers
  26. dodoc CHANGES README mshuffle.txt
  27. doman xfreecell.6
  28. make_desktop_entry xfreecell XFreecell
  29. }
  30. pkg_postinst() {
  31. einfo "Remember to restart X if this is the first time you've installed media-fonts/font-misc-misc"
  32. }