xfreecell-1.0.5b.ebuild 955 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils games
  5. DESCRIPTION="A freecell game for X"
  6. HOMEPAGE="http://www2.giganet.net/~nakayama/"
  7. SRC_URI="http://www2.giganet.net/~nakayama/${P}.tgz
  8. http://www2.giganet.net/~nakayama/MSNumbers.gz"
  9. LICENSE="HPND"
  10. SLOT="0"
  11. KEYWORDS="amd64 ~ppc ppc64 x86"
  12. IUSE=""
  13. RDEPEND="x11-libs/libXext
  14. media-fonts/font-misc-misc"
  15. DEPEND="${RDEPEND}
  16. x11-proto/xextproto"
  17. S=${WORKDIR}/${PN}
  18. src_prepare() {
  19. epatch \
  20. "${FILESDIR}"/${P}-gentoo.patch \
  21. "${FILESDIR}"/${P}-gcc43.patch
  22. }
  23. src_install() {
  24. dogamesbin xfreecell
  25. insinto "${GAMES_DATADIR}"/${PN}
  26. doins "${WORKDIR}"/MSNumbers
  27. dodoc CHANGES README mshuffle.txt
  28. doman xfreecell.6
  29. make_desktop_entry xfreecell XFreecell
  30. prepgamesdirs
  31. }
  32. pkg_postinst() {
  33. games_pkg_postinst
  34. einfo "Remember to restart X if this is the first time you've installed media-fonts/font-misc-misc"
  35. }