hugo-2.12.ebuild 726 B

123456789101112131415161718192021222324252627282930313233343536
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils flag-o-matic games
  5. DESCRIPTION="PC-Engine (Turbografx16) emulator for linux"
  6. HOMEPAGE="http://www.zeograd.com/"
  7. SRC_URI="http://www.zeograd.com/download/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="x86"
  11. IUSE=""
  12. RDEPEND="x11-libs/gtk+:2
  13. media-libs/libsdl[video]
  14. media-libs/libvorbis"
  15. DEPEND="${RDEPEND}
  16. virtual/pkgconfig"
  17. src_prepare() {
  18. epatch "${FILESDIR}/${P}"-gcc41.patch
  19. append-cppflags $(pkg-config sdl --cflags)
  20. }
  21. src_install() {
  22. dogamesbin hugo
  23. insinto "${GAMES_DATADIR}/${PN}"
  24. doins -r pixmaps
  25. dodoc AUTHORS ChangeLog NEWS README TODO
  26. dohtml doc/*html
  27. prepgamesdirs
  28. }